JPA, Hibernate

Hibernate 4.3.0.Final < > Querydsl 3.3.0 충돌 이슈

flowdabbler.com 개발노트 (3) – Hibernate 4.3.0.Final <> Querydsl 3.3.0 충돌이슈 Hibernate 4.3.0.Final 과 Querydsl 3.3.0 을 같이 사용할 경우 아래와 같은 에러가 발생한다 java.lang.NoSuchMethodError: javax.persistence.Table.indexes()[Ljavax/persistence/Index; 이유는 Hibernate 4.3.0.Final 에서는 hibernate-jpa-2.1-api-1.0.0.Final.jar 를 사용하고 Querydsl 3.3.0 에서는 hibernate-jpa-2.0-api-1.0.0.Final.jar 를 사용하기 때문이다 해결방법은 1. 아래와 같이 querydsl-jpa 는 hibernate-jpa-2.0-api를 제외하도록 설정한다 [crayon-5d8129ee1bb6d018401174/] 2. 더 보기…

글쓴이 SilverNine,